Category Archives: Grizzly Engine & Transmission

Grizz 700 Stuck Valve-rings? Smoking

Hey guys,
I have a line on a 07 grizzly 700 for a pretty good price. Owner says it may have a stuck valve or need new rings. He says it smokes a little while driving. Only 2100 miles on it. in great shape. Thought I would be a good one to fix. I am not sure how much this is going to cost to fix or be a problem. I am handy but have not done a valve/ring job before. He was told that it may have a "sticky valve and/or may need rings" Going to look at it today.

i would probably pull the engine If i need to and bring it to someone to repair/rebuild.

Any advice on this subject.

Thanks
Joe

Whats in the EPI Clutch Kit

I am looking to do a clutching overhall.. I know there is 10,000 posts on this already but i was wondering exactly what weights and secondary spring comes in the " sport utility" kit from EPI… just looing at a Tucker Rocky catalog today and doing some simple math i know i can get the whole kit as parts, cheaper than the whole from EPI… I Have a 2014 700 Grizz with 26" mudlights XL all the way around….. just have a slip on exhaust and i ride pretty aggressive most of the time.. Not saying im not just piddlin around sometimes but i came from sport quads so there is a serious disconnect between what i have left of a brain and my right thumb… So far i am thinking 8 18g roller weights, a purple secondary spring and possibly a 1mm shim in the primary and maybe 6 wet clutch +500 rpm springs. am i on the right track with my thinking? O and i weigh about 190 lbs and ride between 0-3000 ft altitude

660 rebuild raptor killer

I’m picking up an 05 grizzly 660 today that is past due for a top end rebuild and I think I’m going to go big with a wiseco high comp piston, new crank, rod, bearings and a hot cam with the associated valve springs. Think that will be too much for the rest of the machine and compromise reliability? If there’s enough interest I’ll post pics through the whole project and keep y’all posted

Going in to the Clutch Box

I need some answers about shims, changing the secondary spring, and replacing a one way bearing. Maybe a custom sheave mod before over.

With cabin fever starting to peak, figure that we can have us a good ole knockdown drag out, cussing, people getting banned, screaming yelling, over which blah blah bah is better.

Lock and Load boys, we are going in :deal:.

Finally dug into my CVT… 10 000kms later.

Well I finally had to open the old girl up. I had the CVT cover off once before just to eyeball things but that was it.

The issue that I noticed this winter is my bike would require a lot more throttle to get moving in high range. Low range not so bad. Reverse seemed to be lacking power. I haven’t been using my Grizz so much the last few winters (trail riding) because I have a blower hooked up with tire chains.

Anyway, I assumed the worse and figured my wet clutch was shot. I ride the old girl hard and creeping threw deep snow pushing a 300lb blower doesn’t help either I’m sure. I also realized that a good primary clutch cleaning wouldn`t hurt either after 10 000kms. :icon_ goofy:

Opened her up on the weekend and got to work. The clutch is very easy to service, cleaning out the old grease was the hardest part. I only put about a tsp of grease in each roller channel and a bit on the sliders. Speaking of the rollers, they have very minimal flat spots. Almost have to run you finger over them to tell. I threw them back in because I doubt that would be causing my high rpm takeoffs.

I had to do an oil change anyway so off came the wet clutch cover. Straight forward process. The impact made quick work of the 140ft-lb wet clutch bolt (reverse thread FYI!). I will continue in the next post with my findings.

2001 600 grizzly starter engages when shifter goes in neutral

I recently got a 600 grizzly from my dad. He’s the orig owner and the quad is unmolested with 450 miles on it. I put a battery in it and it runs like new.i rode it for about a hour then oil temp light came on so I put it in neutral and shut it off. i waited about half hour turned key on and the starter started the motor and stayed engaged. Shifted into high and it disengages with motor running. Then I shifted back into neutral with it still running and the starter engages.
I unplugged the push button assembly. No fix
Unplugged solenoid no start. Plugged back in and starter engaged automatically.
Something between neutral safety switch and starter solenoid it getting power. CDI???

Any help would be greatly appreciated. Thank you

2016 Grizzly Engine Noise

Hey guys & gals, I am new to this forum and new to the Yamaha product "Grizzly 700 EPS". I am in the process of completing the required break in period of 300KM before the first fluid change and was out on the lake yesterday to put some time in and working on the top end "break in" (1/2 to full throttle). Around the 1/2 throttle I was experiencing an elevated high pitch noise coming from the engine. Their is no noise from 0-1/2 or 1/2 to full, it just happens around the 1/2 throttle it also happens in either 2wd or 4wd, no difference, has anyone else noticed this?

Thank you…

2016 Grizzly Engine Noise

Hey guys & gals, I am new to this forum and new to the Yamaha product "Grizzly 700 EPS". I am in the process of completing the required break in period of 300KM before the first fluid change and was out on the lake yesterday to put some time in and working on the top end "break in" (1/2 to full thrittle). Around the 1/2 throttle I was experiencing an elevated high pitch noise coming from the engine. This happens in either 2wd or 4wd, no difference, has anyone else noticed this?

Thank you…

Shifter Jammed

I tried searching the forum but keep getting directed to transmission or linkage problems. I believe my issue is the shifter itself.

06 Grizzly 660 – It wouldn’t shift in to reverse or park. I disconnected the linkage and pulled to the shift shaft cover off – I am able to shift through all gears by hand. With the linkage still disconnected, the shifter itself still won’t physically engage in the reverse or park slots.

I plan to pull the shifter assembly off tomorrow and inspect it.

Here is the kicker – I have a 2nd identical parts bike and it has the same issue. Am I missing something, or could they just be plugged up and dirty? Any insight?

Thanks!